Overblog
Editer l'article Suivre ce blog Administration + Créer mon blog
30 mars 2013 6 30 /03 /mars /2013 16:40

Je souhaite simplement ici partager une expérience qui peut arriver à d'autres, surtout avec des environnements en production, vieillissants pour ne pas dire obsolètes.

Ubuntu 6, obsolète ? oui, largement. Mais dans la vraie vie, il n'est pas du tout improbable de la trouver en prod.

 

Tout part donc d'une Ubuntu 6.04. Voici quelques points et astuces que je vous recommande de prendre en compte durant la migration :

 

- le système do-release-upgrade  ne marche quasiment jamais. Principalement car les fichiers à télécharger ne sont plus en ligne. Il faudra donc éditer manuellement le fichier sources.list.

 

- les dépôts Security (security.ubuntu.com) ne marchent pas, le fichier à télécharger par APT n'est pas (plus) accessible. Ils peuvent à mon avis être temporairement désactivés.

 

- différents paquets ne passeront pas le cap tous seuls, avec APT. Quelques exemples : hal, network-manager, pidgin, gaim, mod_security.

Pour le passage à Lucid, AppArmor et MySQL remonteront aussi des erreurs, mais cela ne stoppera pas les opérations APT pour autant. Par contre, Libpurple0 elle pourra devenir vraiment bloquante (j'ai du installer les dépendances à la main ave dpkg -i , puis relancer dpkg --reconfigure -a).

 

La suite à venir...

 

 

Partager cet article

Repost0

commentaires